HDU1506 Largest Rectangle in a Histogram

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 
 
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
InputThe input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.OutputFor each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8

4000

PS:由题得,柱形的高度,就是对应柱形的面积,所以要求的是最低高度最小的一段柱形。可以声明两个数组记录所遍历柱形的左边和右边比该柱形,比该矩形高度高的的柱形的位置。最后在遍历一次,选出最大的面积。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;	
int a[300005];
int l[300005],r[300005];
int main()
{
	int n;
	while(scanf("%d",&n)&&n)
	{
		memset(a,0,sizeof(a));
		memset(l,0,sizeof(l));
		memset(r,0,sizeof(r));
		for(int i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(int i=0;i<n;i++)
		{
			l[i]=i;
			while(l[i]>0&&a[l[i]-1]>=a[i])
				l[i]=l[l[i]-1];
		}
		for(int i=n-1;i>=0;i--)
		{
			r[i]=i;
			while(r[i]<n-1&&a[r[i]+1]>=a[i])
				r[i]=r[r[i]+1];
		}
		long long maxn=-1;
		for(int i=0;i<n;i++)
		if((long long)(r[i]-l[i]+1)*a[i]>maxn)
			maxn=(long long)(r[i]-l[i]+1)*a[i];
		cout<<maxn<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41292370/article/details/80962025