Largest Rectangle in a Histogram HDU - 1506

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 
 
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

题意:
    给定n个矩形条,每个矩形条高,求最大矩形面积。
思路:
枚举每个点i,找连续h[j]>=h[i]的j的最大,最小值。对于每一个h[i],用dp找出h[i]左边和右边连续大于自己的数的长度
代码:


#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
#define LL long long
LL  h[100100],l[100100],r[100100],maxx,s;//l[i]表示比h[i]大的数连续的最左边的位置r[i]表示比h[i]大的数连续的最右边的位置
int main()
{
    int n;
    while(scanf("%d",&n) && n)
    {
        for(int i=1;i<=n;i++)
        scanf("%I64d",&h[i]);
        l[1]=1;
        r[n]=n;
        for(int i=2;i<=n;i++)
        {
            int t=i;
            while(t>1&&h[i]<=h[t-1]) t=l[t-1];//dp思想
            l[i]=t;
        }
        for(int i=n-1;i>=1;i--)
        {
            int t=i;
            while(t<n&&h[i]<=h[t+1]) t=r[t+1];
            r[i]=t;
        }
        maxx=0;
        for(int i=1;i<=n;i++)
        {
            s=(r[i]-l[i]+1)*h[i];
            if(s>maxx)
            maxx=s;
        }
        printf("%I64d\n",maxx);
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/Qtt110/article/details/81434062