HDU - 1686 Oulipo (字符串Hash)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chimchim04/article/details/89487387

Oulipo 

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: 

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais… 

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces. 

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap. 
 

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format: 

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W). 
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000. 

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T. 
 

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

题目大意:给出串s1,s2,求s1在s2中出现的次数

思路:字符串Hash求子串出现的次数模板题

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ull unsigned long long
const int N=1000005;
const int c=1331;
char s[N],p[N];
ull ha[N],hp[N];
int n,m;
void init()
{
    ha[0]=1;
    for(int i=1;i<=1000000;i++)
        ha[i]=ha[i-1]*c;
}
int main()
{
    init();
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s%s",s,p);
        m=strlen(s),n=strlen(p);
        ull x=0;
        for(int i=0;i<m;i++)
            x=x*c+(ull)(s[i]-'A'+1);
        hp[0]=(ull)(p[0]-'A'+1);
        for(int i=1;i<n;i++)
            hp[i]=hp[i-1]*c+(ull)(p[i]-'A'+1);
        int ans=0;
        if(hp[m-1]==x) ans++;
        for(int i=1;i<=n-m;i++)
            if(hp[i+m-1]-hp[i-1]*ha[m]==x) ans++;
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/89487387