【 HDU - 1686 】L - Oulipo (KMP)

题目:

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

代码:

(KMP模板题)

#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
int t,Next[10050]; //next数组
string s1,s2;

void getNext(string s) //获得next数组
{
    
    
	int len=s.length();
	fill(Next,Next+10050,0);
	int j=-1;
	Next[0]=-1;
	for(int i=1;i<len;i++)
	{
    
    
		while(j!=-1 && s[i]!=s[j+1]){
    
    
			j=Next[j];
		}
		if(s[i]==s[j+1]) j++;
		Next[i]=j;
	}
}

int kmp(string s1,string s2) 
{
    
    
	int len1=s1.size(),len2=s2.size(),ans=0;
	getNext(s2);
	int j=-1;
	for(int i=0;i<len1;i++)
	{
    
    
		while(j!=-1 && s1[i]!=s2[j+1]){
    
    
			j=Next[j];
		}
		if(s1[i]==s2[j+1]) j++;
		if(j==len2-1) //匹配成功
		{
    
    
			ans++; 
			j=Next[j]; //回到next[j]
		}
	}
	return ans;
}

int main()
{
    
    
	cin>>t;
	while(t--)
	{
    
    
		cin>>s1>>s2;
		cout<<kmp(s2,s1)<<endl; //在s1中找s2
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_45260385/article/details/108220155