poj3461 && hdu1686 Oulipo KMP && HASH哈希

Oulipo

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: 

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais… 

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces. 

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap. 
 

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format: 

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W). 
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000. 

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T. 
 

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

思路:

这道题两种做法,KMP更省时间,Hash很有意思,索性都写出来

代码:

KMP做法:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = (int)1e6 + 10;
const int MAXN = (int)1e4 + 10;
char f[maxn],s[MAXN];
int nxt[MAXN];

void init(int m)
{
	int i = 1,j = 0;
	nxt[0] = 0;
	while (i < m)
	{
		if (s[i] == s[j])
			nxt[i ++] = ++ j;
		else if (!j)
			i ++;
		else
			j = nxt[j - 1];
	}
}
int kmp(int n,int m)
{
	int i = 0,j = 0,res = 0;
	while (i < n)
	{
		if (s[j] == f[i])
			i ++,j ++;
		else if (!j)
			i ++;
		else
			j = nxt[j - 1];
		if (j == m)
		{
			j = nxt[j - 1],res ++;
		}
		
	}
	return res;
}
int main()
{
	int t;
	scanf("%d",&t);
	while (t --)
	{
		scanf("%s %s",s,f);
		int len = strlen(s),n = strlen(f);
		init(len);
		printf("%d\n",kmp(n,len));
	}
	return 0;
} 

Hash做法:

#include<cstdio>
#include<cstring>
#include<algorithm>
#define ull unsigned long long
using namespace std;
const int maxn = (int)1e6 + 10;
ull p = 10007,v;
ull has[maxn];
char str[10010];
char str2[maxn];
int main()
{
	int t;
	scanf("%d",&t);
	while (t --)
	{
		v = 1;
		scanf("%s",str + 1);
		scanf("%s",str2 + 1);
		int len1 = strlen(str + 1),len2 = strlen(str2 + 1);
		ull s = 0;
		for (int i = 1;i <= len1;i ++)
		{
			s = s * p + str[i] - 'A' + 1;
				v = v * p;
		}
		has[0] = 0;
		for (int i = 1;i <= len2;i ++)
		{
			has[i] = has[i - 1] * p + str2[i] - 'A' + 1;
		}
		int ans = 0;
		for (int i = 1;i <= len2 - len1 + 1;i ++)
		{
			ull temp = has[i + len1 - 1] - has[i - 1] * v;
			if (temp == s) ans ++;
		}
		printf("%d\n",ans);
	 } 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/81814246
今日推荐