HDU1686 Oulipo(字符串哈希)

HDU1686 Oulipo(字符串哈希)

Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0

题意

给定一个字符串str1,和一个字符串str2,问str1在str2中的出现次数。
取字符串中间一段Hash值的结论
在这里插入图片描述
Soft_sister大佬提供,wgg太帅了呜呜

#include<bits/stdc++.h>
#define lowbit(x) ((x)&-(x));
using namespace std;
typedef long long ll;
const int N=1e6+10,NN=2e3+10,INF=0x3f3f3f3f;
const ll MOD=1e9+7;
int n,key,len1,len2,ans;
int Hash[N],p[N];
char str1[N],str2[N]; 
unsigned int Hashstr1(){
	int sum=0;
	for(int i=1;i<=len1;i++) sum=sum*31+str1[i];
	return sum;
}
void Hashstr2(){
	int sum=0;
	Hash[0]=0;
	for(int i=1;i<=len2;i++) Hash[i]=Hash[i-1]*31+str2[i];
	return ;
}
void init(){
	p[0]=1;
	for(int i=1;i<N;i++) p[i]=p[i-1]*31;
}
int main(){
	scanf("%d",&n);
	init();
	while(n--){
		scanf("%s %s",str1+1,str2+1);
		len1=strlen(str1+1);
		key=Hashstr1();
		len2=strlen(str2+1);
		Hashstr2();
		ans=0;
		for(int i=1;i+len1-1<=len2;i++){
			int temp=Hash[i+len1-1]-Hash[i-1]*p[len1];//求出区间[i,i+len1-1]这一段的hash值
			if(temp==key) ++ans;
		}
		printf("%d\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Hc_Soap/article/details/107577412