HDU-1686Oulipo(kmp)

                                                       Oulipo


Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

题意描述:

找出a串中包含多少个b串

程序代码:

#include<stdio.h>
#include<string.h>
void get_next();
int next[10010],m,n;
char a[1000010],b[10010];
int main()
{
	int T,i,j,count;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%s%s",b,a);
		n=strlen(a);
		m=strlen(b);
		get_next();
		i=0;
		j=0;
		count=0;
		while(i<n)
		{
			if(j==0&&a[i]!=b[j])
				i++;
			else if(j>0&&a[i]!=b[j])
				j=next[j-1];
			else
			{
				i++;
				j++;
			}
			if(j==m)
			{
				j=next[j-1];
				count++;
			}
		}
		printf("%d\n",count);
	}
	return 0;
}
void get_next()
{
	int i,j;
	i=1;
	j=0;
	next[0]=0;
	while(i<m)
	{
		if(j==0&&b[i]!=b[j])
		{
			next[i]=0;
			i++;
		}
		else if(j>0&&b[i]!=b[j])
			j=next[j-1];
		else
		{
			next[i]=j+1;
			i++;
			j++;
		}
	}
}

猜你喜欢

转载自blog.csdn.net/hezhiying_/article/details/81156126