HDU - 1686 Oulipo(kmp计数)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chenshibo17/article/details/81772704

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: 

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais… 

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces. 

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap. 
 

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format: 

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W). 
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000. 

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T. 
 

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

    本来就是一个简单的kmp计数。。。但是我莫名其妙突然tle了一次,法现问题后就来记录一次;

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 1000100;
char m[maxn], n[maxn];
int nex[maxn];
void getne(char *str, int len) {
	int i = 0, j = -1;
	nex[0] = -1;
	while (i < len) {
		if (j == -1 || str[i] == str[j]) {
			nex[++i] = ++j;
		}
		else
			j = nex[j];
	}
}
int kmp(char *a, char *b, int lena, int lenb) {
	int sum = 0;
	int i = 0, j = 0;
	while (i < lena&&j < lenb) {
		if (j == -1 || a[i] == b[j])
			++j, ++i;
		else
			j = nex[j];
		if (j == lenb) {
			sum++;
            //i--; 之前我加了这句话就t了。。
			j = nex[j];
		}
	}
	return sum;
}
int main() {
	int te;
	scanf("%d", &te);
	while (te--) {
		scanf("%s", n);
		scanf("%s", m);
		int a = strlen(n), b = strlen(m);
		getne(n, a);
		printf("%d\n", kmp(m, n, b, a));
	}
}

猜你喜欢

转载自blog.csdn.net/chenshibo17/article/details/81772704