hdu1686:Oulipo

http://acm.hdu.edu.cn/showproblem.php?pid=1686

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
 

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
 

扫描二维码关注公众号,回复: 2830713 查看本文章

Sample Input

3

BAPC

BAPC

AZA

AZAZAZA

VERDI

AVERDXIVYERDIAN

Sample Output

1

3

0

求a字符串在b字符串中出现了几次,kmp算法题,要注意的地方是在匹配完成之后要继续匹配。另一道相似的题https://blog.csdn.net/qq_41505957/article/details/81713361

#include<stdio.h>
#include<string.h>
#define N 100020
char a[10*N],b[N];
int l1,l2,next[N],ans;
void get_next()
{
	int i,j;
	i=0;
	j=-1;
	next[0]=-1;
	while(i<l2)
	{
		if(j==-1||b[i]==b[j])
		{
			i++;
			j++;
			next[i]=j;
		}
		else
			j=next[j];
	}
}
void kmp()
{
	int i,j;
	i=0;
	j=0;
	get_next();
	while(i<l1)
	{
		if(j==-1||a[i]==b[j])
		{
			i++;
			j++;
		}
		else
			j=next[j];
		if(j>=l2)
        {
            j=next[j];              
            ans++;
        }
	}
}
int main()
{
	int k;
	scanf("%d",&k);
	while(k--)
	{
		ans=0;
		scanf("%s%s",b,a);
		l1=strlen(a);
		l2=strlen(b);
		memset(next,0,sizeof(next));
		kmp();
		printf("%d\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41505957/article/details/81712690
今日推荐