[KMP] B - Oulipo HDU - 1686

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22488    Accepted Submission(s): 8683


 

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

 

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

 

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
 

 

Sample Input

 

3

BAPC

BAPC

AZA

AZAZAZA

VERDI

AVERDXIVYERDIAN

 

Sample Output

 

1

3

0

 

Source

华东区大学生程序设计邀请赛_热身赛

#include <bits/stdc++.h>
using namespace std;

const int mn = 1000010, mm = 10010;

int n, m;
char a[mm], b[mn];
int nx[mm];

void cal_next(char b[])
{
	nx[0] = -1;
	int k = -1;
	for (int i = 1; i <= m - 1; i++)
	{
		while (k > -1 && b[k + 1] != b[i])
			k = nx[k];
		if (b[k + 1] == b[i])
			k++;
		nx[i] = k;
	}
}

int KMP(char a[], char b[])
{
	int cnt = 0;
	cal_next(b);
	int k = -1;
	for (int i = 0; i < n; i++)
	{
		while (k > -1 && b[k + 1] != a[i])
			k = nx[k];
		if (b[k + 1] == a[i])
			k++;
		if (k == m - 1)
			cnt++;
	}
	return cnt;
}

int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%s", a);
		scanf("%s", b);
		m = strlen(a);
		n = strlen(b);
		printf("%d\n", KMP(b, a));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/81838439