YTU 3134 动态规划基础题目之数字三角形

版权声明:转载请附上原文链接哟! https://blog.csdn.net/weixin_44170305/article/details/90056233

风华是一指流砂,苍老是一段年华。

题目描述

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

输出

Your program is to write to standard output. The highest sum is written as an integer.

样例输入

copy

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

样例输出

30

提示

这是动归题目,要有动归思维,即便是递归也需要一点改进。

#include<iostream>
#include<cstdio>
int a[100][100];
int *sum,n;
using namespace std;
int main()
{
    int i,j;
    cin>>n;
    for(i=1;i<=n;i++)
        for(j=1;j<=i;j++)
        cin>>a[i][j];
    sum=a[n];
    for(int i=n-1;i>=1;i--)
        for(j=1;j<=i;j++)
        sum[j]=max(sum[j],sum[j+1])+a[i][j];
    cout<<sum[1]<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44170305/article/details/90056233
今日推荐