Problem C: 动态规划基础题目之数字三角形

Problem C: 动态规划基础题目之数字三角形

Time Limit: 1 Sec  Memory Limit: 64 MB
Submit: 208  Solved: 139
[Submit][Status][Web Board]

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30
#include<stdio.h>
int main()
{
    int a[20][20];
    int i,j;
    int n;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
        for(j=1;j<=i;j++)
            scanf("%d",&a[i][j]);
    for(i=n;i>=1;i--)
    {
        for(j=1;j<=i;j++)
        {
            a[i-1][j]+=(a[i][j]>a[i][j+1]?a[i][j]:a[i][j+1]);
        }
    }
    printf("%d",a[1][1]);
    return 0;
}

  

 

猜你喜欢

转载自www.cnblogs.com/mjn1/p/9002194.html