PAT 甲级 1144 The Missing Number

https://pintia.cn/problem-sets/994805342720868352/problems/994805343463260160

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

代码:
#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e5 + 10;
int a[maxn], num[maxn];

int main() {
    int n;
    scanf("%d", &n);
    for(int i = 1; i <= n; i ++) {
        scanf("%d", &a[i]);
        if(a[i] < 0 || a[i] > n + 1) continue;
        else
            num[a[i]] ++;
    }

    for(int i = 1; i <= n; i ++) {
        if(num[i] == 0) {
           printf("%d\n", i);
           return 0;
        }
    }
    printf("%d\n", n + 1);
    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/zlrrrr/p/9420588.html