PAT 甲级 1024 Palindromic Number

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a845717607/article/details/86582228

1024 Palindromic Number (25 point(s))

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

Experiential Summing-up

This question is the PAT 甲级 1019 General Palindromic Number's similar version. Not difficult. Just notice that all single digit numbers are palindromic numbers.That's all~

(The purpose of using English to portray my solution is that to exercise the ability of my expression of English and accommodate PAT advanced level's style.We can make progress together by reading and comprehending it. Please forgive my basic grammar's and word's error. Of course, I would appreciated it if you can point out my grammar's and word's error in comment section.( •̀∀•́ ) Furthermore, Big Lao please don't laugh at me because I just a English beginner settle for CET6    _(:з」∠)_  )

Accepted Code

#include <cstdio>
#include <cstring>
using namespace std;

struct bign
{
	int len;
	int d[110];
	bign()
	{
		len=0;
		memset(d,0,sizeof(d));
	}
};
bign convert(char s[])
{
	bign a;
	a.len=strlen(s);
	for(int i=a.len-1;i>=0;--i)
	{
		a.d[a.len-1-i]=s[i]-'0';
	}
	return a;
}
bign add(bign a)
{
	bign c;
	int carry=0;
	c.len=0;
	for(int i=0;i<a.len;++i)
	{
		int temp=a.d[i]+a.d[a.len-1-i]+carry;
		c.d[c.len++]=temp%10;
		carry=temp/10;
	}
	if(carry!=0)
	{
		c.d[c.len++]=carry;
	}
	return c;
}
bool judge(bign a)
{
	for(int i=0;i<a.len/2;++i)
	{
		if(a.d[i]!=a.d[a.len-1-i])
			return false;
	}
	return true;
}
int main()
{
	char s[30];
	int k;
	scanf("%s %d",s,&k);
	bign a=convert(s);
	int step;
	bign ans;
	for(step=0;step<k;++step)
	{
		if(judge(a))
		{
			break;
		}
		a=add(a);
	}
	for(int i=a.len-1;i>=0;--i)
	{
		printf("%d",a.d[i]);
	}
	printf("\n%d\n",step>k?k:step);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/a845717607/article/details/86582228