HDU - 5050 (大数二进制gcd)

It’s time to fight the local despots and redistribute the land. There is a rectangular piece of land granted from the government, whose length and width are both in binary form. As the mayor, you must segment the land into multiple squares of equal size for the villagers. What are required is there must be no any waste and each single segmented square land has as large area as possible. The width of the segmented square land is also binary.

Input

The first line of the input is T (1 ≤ T ≤ 100), which stands for the number of test cases you need to solve. 

Each case contains two binary number represents the length L and the width W of given land. (0 < L, W ≤ 2 1000)

Output

For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then one number means the largest width of land that can be divided from input data. And it will be show in binary. Do not have any useless number or space.

Sample Input

3
10 100
100 110
10010 1100

Sample Output

Case #1: 10
Case #2: 10
Case #3: 110

代码:

import java.io.BufferedInputStream;
import java.math.BigInteger;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO 自动生成的方法存根
		Scanner str = new Scanner(System.in);
		int T;
		T=str.nextInt();
		int i=1;
		

		for(i=1;i<=T;i++)
		{
			String st,st1;
			st=str.next();
			st1=str.next();
			BigInteger a=new BigInteger(st,2);
			BigInteger b=new BigInteger(st1,2);
			BigInteger c=a.gcd(b);
			System.out.println("Case #"+i+": "+c.toString(2));
			
			
		}

	}

}

猜你喜欢

转载自blog.csdn.net/lbperfect123/article/details/89215241