【HDU - 5050 】Divided Land (Java大数,大数进制转换,大数gcd)

版权声明:欢迎学习我的博客,希望ACM的发展越来越好~ https://blog.csdn.net/qq_41289920/article/details/89026414

题干:

It’s time to fight the local despots and redistribute the land. There is a rectangular piece of land granted from the government, whose length and width are both in binary form. As the mayor, you must segment the land into multiple squares of equal size for the villagers. What are required is there must be no any waste and each single segmented square land has as large area as possible. The width of the segmented square land is also binary.

Input

The first line of the input is T (1 ≤ T ≤ 100), which stands for the number of test cases you need to solve. 

Each case contains two binary number represents the length L and the width W of given land. (0 < L, W ≤ 2 1000)

Output

For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then one number means the largest width of land that can be divided from input data. And it will be show in binary. Do not have any useless number or space.

Sample Input

3
10 100
100 110
10010 1100

Sample Output

Case #1: 10
Case #2: 10
Case #3: 110

题目大意:

  读入二进制形式的两个数,让你以二进制的形式输出他俩对应十进制数字的gcd。

解题报告:

扫描二维码关注公众号,回复: 5799729 查看本文章

不得不说一句,IDEA牛逼。所有功能全都自动补全出来。

AC代码:

import java.math.*;
import java.util.Scanner;
public class Main{

    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        int t;
        t = cin.nextInt();
        BigInteger a,b;
        for(int i = 1; i<=t; i++) {
           a= cin.nextBigInteger(2);
           b= cin.nextBigInteger(2);
           System.out.print("Case #" + i + ": ");
            System.out.println(a.gcd(b).toString(2));
        }

    }
}

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/89026414