HDU5573 Binary Tree 二进制+规律

http://acm.hdu.edu.cn/showproblem.php?pid=5573

Binary Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2018    Accepted Submission(s): 1206
Special Judge

 

Problem Description

The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1 . Say froot=1 .

And for each node u , labels as fu , the left child is fu×2 and right child is fu×2+1 . The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly N soul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x , the number at the node is fx (remember froot=1 ), he can choose to increase his number of soul gem by fx , or decrease it by fx .

He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N , then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given N , K , help the King find a way to collect exactly N soul gems by visiting exactly K nodes.

 

Input

First line contains an integer T , which indicates the number of test cases.

Every test case contains two integers N and K , which indicates soul gems the frog king want to collect and number of nodes he can visit.

⋅ 1≤T≤100 .

⋅ 1≤N≤109 .

⋅ N≤2K≤260 .

 

Output

For every test case, you should output "Case #x:" first, where x indicates the case number and counts from 1 .

Then K lines follows, each line is formated as 'a b', where a is node label of the node the frog visited, and b is either '+' or '-' which means he increases / decreases his number by a .

It's guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.
 

 

Sample Input

 

2 5 3 10 4

 

Sample Output

 

Case #1: 1 + 3 - 7 + Case #2: 1 + 3 + 6 - 12 +

#include<bits/stdc++.h>
using namespace std;
long long n,k;
int flag = 0;
int a[666];
int main()
{
//只走二叉树的最左边那个道路,
    int t;
    scanf("%d",&t);
    for(int cases=1; cases<=t; cases++)
    {
        scanf("%lld%lld",&n,&k);
        flag = 0;
        memset(a,0,sizeof(a));
        if(n%2==0)
        {
            flag = 1;
            n = n-1;//偶数的情况,把它变成奇数;
        }
        int tmp = 0;
        for(int i=k-1; i>=0; i--)
        {//找规律,看哪些需要+,哪些需要减;
            a[i]=1-tmp;
            tmp=1;
            if((n>>i)&1)
                tmp=0;
            //cout<<(n>>i)<<"dfsd"<<((n>>i)&1)<<endl;
        }//
        printf("Case #%d:\n",cases);
        long long now = 1;
        for(int i=0; i<k-1; i++)
        {
            printf("%lld ",now);
            now = now*2;//只输出2的n次方;
            if(a[i])printf("+\n");
            else printf("-\n");//
        }
        if(flag)printf("%lld ",now+1);
        else printf("%lld ",now);//如果是偶数,那么往右拐一下;
        if(a[k-1])printf("+\n");
        else printf("-\n");
    }
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/86530122