HDU 4810 Wall Painting (思维+二进制优化)

版权声明:本文为博主原创文章,转载请标明原博客。 https://blog.csdn.net/sdau_fangshifeng/article/details/86513580

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=4810

Wall Painting

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4382    Accepted Submission(s): 1480

Problem Description

Ms.Fang loves painting very much. She paints GFW(Great Funny Wall) every day. Every day before painting, she produces a wonderful color of pigments by mixing water and some bags of pigments. On the K-th day, she will select K specific bags of pigments and mix them to get a color of pigments which she will use that day. When she mixes a bag of pigments with color A and a bag of pigments with color B, she will get pigments with color A xor B.
When she mixes two bags of pigments with the same color, she will get color zero for some strange reasons. Now, her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will get with different plans.

For example, assume n = 3, K = 2 and three bags of pigments with color 2, 1, 2. She can get color 3, 3, 0 with 3 different plans. In this instance, the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6.
Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him?
You should tell Mr.Fang the answer from the first day to the n-th day.

Input

There are several test cases, please process till EOF.
For each test case, the first line contains a single integer N(1 <= N <= 103).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag.

Output

For each test case, output N integers in a line representing the answers(mod 106 +3) from the first day to the n-th day.

Sample Input

4

1 2 10 1

Sample Output

14 36 30 8

思路来源:https://blog.csdn.net/sdz20172133/article/details/86500798

This is the code:

#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<sstream>
#include<stack>
#include<string>
#include<set>
#include<vector>
using namespace std;
#define PI acos(-1.0)
#define EPS 1e-8
#define LL long long
#define ULL unsigned long long     //1844674407370955161
#define INT_INF 0x7f7f7f7f      //2139062143
#define LL_INF 0x7f7f7f7f7f7f7f7f //9187201950435737471
// ios::sync_with_stdio(false);
// 那么cin, 就不能跟C的 scanf,sscanf, getchar, fgets之类的一起使用了。
#define N 1005
const int mod=1e6+3;

int n;
int num[35];
LL C[N][N],ans[N];

void Initial()//杨辉三角初始化,注意取模
{
    for(int i=0; i<N; ++i)
    {
        C[0][i] = 0;
        C[i][0] = 1;
    }
    for(int i=1; i<N; ++i)
    {
        for(int j=1; j<N; ++j)
            C[i][j] = (C[i-1][j] + C[i-1][j-1])%mod;
    }
}
int main()
{
    Initial();
    while(scanf("%d",&n)!=-1)
    {
        memset(num,0,sizeof(num));
        memset(ans,0,sizeof(ans));
        int maxx=0;
        for(int i=1; i<=n; i++)
        {
            LL x;
            int cnt=1;
            scanf("%lld",&x);
            while(x)//寻找二进制
            {
                if(x&1)
                    num[cnt]++;
                x=x>>1;
                cnt++;
            }
            maxx=max(maxx,cnt);//二进制最高位
        }

        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<maxx; j++)
            {

                LL val=(1<<(j-1));
                for(int k=1; k<=num[j]&&i>=k; k+=2)//注意是奇数
                    ans[i]=(ans[i]+C[num[j]][k]*C[n-num[j]][i-k]%mod*val%mod)%mod;
            }
        }
        for(int i=1; i<n; i++)
            printf("%lld ",ans[i]);//格式
        printf("%lld\n",ans[n]);

    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/sdau_fangshifeng/article/details/86513580