HDU - 2844——二进制优化多重背包

Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4
以前没见过 这种写法,现在才知道原来还可以用二进制优化多重背包,难怪我一直t。
就是如果一个数的价值乘数量大于m的话,就可以直接用完全背包,否则就用01背包,而k的作用就在于可以吧所有方法都找一遍但是可以缩减时间,最后再来一个剩下的01背包,如果是6的话,123都有了。

#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
int dp[100005],val[100005],num[100005];
void zeroonepack(int n,int wei,int val)
{
     for(int i=n;i>=wei;i--)
     dp[i]=max(dp[i],dp[i-wei]+val);
}
void completepack(int n,int wei,int val)
{
     for(int i=wei;i<=n;i++)
     dp[i]=max(dp[i],dp[i-wei]+val);
}
int multiplepack(int n,int c)
{
     for(int i=1;i<=n;i++)
     {
          if(val[i]*num[i]>=c)
          completepack(c,val[i],val[i]);
     else
     {
          int k=1;
          while(k<num[i])
          {
              zeroonepack(c,k*val[i],k*val[i]);
              num[i]-=k;
              k*=2;
          }
          zeroonepack(c,num[i]*val[i],num[i]*val[i]);
     }
 }
 int ans=0;
 for(int i=1;i<=c;i++)
     if(dp[i]==i)
         ans++;
 return ans;
}
int main()
{
 int n,c;
 while(scanf("%d%d",&n,&c)!=EOF)
 {
      if(n==0&&c==0)
          break;
      memset(dp,0,sizeof(dp));
      for(int i=1;i<=n;i++)
          scanf("%d",&val[i]);
      for(int i=1;i<=n;i++)
          scanf("%d",&num[i]);
      printf("%d\n",multiplepack(n,c));
 }
 return 0; 
}

猜你喜欢

转载自blog.csdn.net/tianyizhicheng/article/details/82011391