HDU 1059(多重背包加二进制优化)

http://acm.hdu.edu.cn/showproblem.php?pid=1059

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29901    Accepted Submission(s): 8501


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 
Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 
Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.
 
Sample Input
1 0 1 2 0 0 
1 0 0 0 1 1
0 0 0 0 0 0
 
Sample Output
Collection #1: Can't be divided.
 
Collection #2: Can be divided.
 
Source
多重背包加二进制优化问题
背包容量为物品总价值的一半,如果总价值为奇数则肯定不可以分
#include<bits/stdc++.h>
using namespace std;
#define max_v 120000
#define max_n 7
int num[max_n],f[max_v],v[max_n]={0,1,2,3,4,5,6};
void ZeroOnePack(int cost,int weight,int c)
{
    for(int v=c;v>=cost;v--)
    {
        f[v]=max(f[v],f[v-cost]+weight);
    }
}
void CompletePack(int cost,int weight,int c)
{
    for(int v=cost;v<=c;v++)
    {
        f[v]=max(f[v],f[v-cost]+weight);
    }
}
void MultiplePack(int cost,int weight,int amount,int c)
{
    if(cost*amount>=c)
    {
        CompletePack(cost,weight,c);
        return ;
    }
    int k=1;
    while(k<amount)
    {
        ZeroOnePack(k*cost,k*weight,c);
        amount-=k;
        k*=2;
    }
    ZeroOnePack(amount*cost,amount*weight,c);
}
int main()
{
    int t=0;
    while(1)
    {
        int sum=0,flag=0;
        for(int i=1;i<max_n;i++)
        {
            scanf("%d",&num[i]);
            sum=sum+i*num[i];
        }
        if(sum==0)
            break;
        if(sum%2==1)
        {
             printf("Collection #%d:\nCan't be divided.\n\n",++t);
             continue;
        }
        sum=sum/2;
        memset(f,0,sizeof(f));
        for(int i=1;i<max_n;i++)
        {
            MultiplePack(v[i],v[i],num[i],sum);
        }
        //printf("%d\n",f[sum]);
        if(f[sum]==sum)
        {
            flag=1;
        }
        if(flag==1)
        {
            printf("Collection #%d:\nCan be divided.\n\n",++t);
        }else
        {
            printf("Collection #%d:\nCan't be divided.\n\n",++t);
        }
    }
    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/yinbiao/p/9141505.html