PAT --甲级1013(1013 Battle Over Cities)

版权声明:Please work hard for your dreams. https://blog.csdn.net/calculate23/article/details/89499841

1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1city_1city1-city2city_2city2 and city1city_1city1-city3city_3city3. Then if city1city_1city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2city_2city2-city3city_3city3.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers NNN (<1000<1000<1000), MMM and KKK, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then MMM lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to NNN. Finally there is a line containing KKK numbers, which represent the cities we concern.

Output Specification:

For each of the KKK cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

给n,m,k分别代表1~n的点,m条边,k个假设要删的点。接下来m行输入边,最后一行输入k个点。问k组假设要删的点删除后会形成几部分。

思路1
很显然如果删除的点为桥的话至少都会形成两部分,所以还要加一条边使其联通,最多形成n-1部分,要加n-2条边,根据这个规律就可以模拟,利用到并查集,删点(其实就等于是在删边)可以在并查集连接的时候判断一下。这种思路无法得满分,最后一组样例会超时的原因居然是要关同步流…

Code

#include <bits/stdc++.h>

using namespace std;
const int maxn = (int)1e3+5;

int N, M, K;
int vis[maxn];
vector<int> edge[maxn];

int find(int x) {
	if (x == vis[x]) {
		return x;
	}
	vis[x] = find(vis[x]); //路径压缩
	return vis[x];
}

void Union (int u, int v) {
	int x = find(u);
	int y = find(v);
	if (x != y) {
		vis[y] = x;
	}
}

int solve (int v) {
	for (int i = 1; i <= N; i++) {
		if (i == v) continue;
		for (int j = 0; j < edge[i].size(); j++) {
			if (edge[i][j] == v) continue;
			Union(i, edge[i][j]);
		}
	}
	int res = -2;
	for (int i = 1; i <= N; i++) {
		if (vis[i] == i) res++;
	}
	return res;
}

int main() {
	ios::sync_with_stdio(false);
	cin.tie(0);cout.tie(0);
	int u, v;
	cin >> N >> M >> K;
	for (int i = 1; i <= N; i++) edge[i].clear();
	for (int i = 0; i < M; i++) {
		cin >> u >> v;
		edge[v].push_back(u);
	}
	for (int i = 0; i < K; i++) {
		cin >> v;
		for (int i = 1; i <= N; i++) {
			vis[i] = i;
		}
		cout << solve(v) << endl;
	}
	return 0;
}

思路2
其实和思路1很像…只不过思路1用到了并查集来维护各个不同的联通分量,而思路2则是利用到深搜或者是广搜求联通分量的个数。

#include <bits/stdc++.h>

using namespace std;
const int maxn = (int)1e3+5;

int N, M, K;
bool vis[maxn];
vector<int> edge[maxn];

void dfs (int u) {
	vis[u] = true;
	for (int i = 0; i < edge[u].size(); i++) {
    if (!vis[edge[u][i]]) {
			dfs(edge[u][i]);
		}
	}
}

int main() {
	ios::sync_with_stdio(false);
	cin.tie(0);cout.tie(0);
	int u, v, cnt;
	cin >> N >> M >> K;
	for (int i = 1; i <= N; i++) edge[i].clear();
	for (int i = 0; i < M; i++) {
		cin >> u >> v;
		edge[v].push_back(u);
		edge[u].push_back(v);
	}
	for (int i = 0; i < K; i++) {
		cin >> v;
		memset(vis, false, sizeof(vis));
		vis[v] = true;
		cnt = -1;
		for (int i = 1; i <= N; i++) {
			if (!vis[i]) {
				dfs(i);
				cnt++;
			}
		}
		cout << cnt << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/calculate23/article/details/89499841