【PAT 甲级】1013 Battle Over Cities (25)(dfs/并查集)

题目链接

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.


For example, if we have 3 cities and 2 highways connecting city~1~-city~2~ and city~1~-city~3~. Then if city~1~ is occupied by the enemy, we must have 1 highway repaired, that is the highway city~2~-city~3~.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (&lt1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

3 2 3
1 2
1 3
1 2 3

Sample Output

1
0
0

题意:给定n个节点组成的一个连通图,k次询问,每次询问删掉其中一个节点后需要多少条边才能重新成为一个连通图。

思路:求连通分量题型。可以用并查集或者dfs,并查集写法类似【天梯赛】 L2-013. 红色警报(并查集)

扫描二维码关注公众号,回复: 2127589 查看本文章

代码【dfs】:

#include <iostream>
#include <sstream>
#include <string>
#include <cstdio>
#include <queue>
#include <cstring>
#include <map>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int N = 1e3+5;
const ll INF = 0x3f3f3f3f;
const double eps=1e-4;
const int T=3;

vector<int>g[N];
bool vis[N];
void dfs(int u) {
    vis[u]=1;
    for(auto x: g[u]) {
        if(!vis[x]) {
            dfs(x);
        }
    }
}
void init(int n) {
    for(int i=0; i<=n; i++) {
        vis[i]=0;
    }
}
int main() {
    int n,m,k;
    scanf("%d%d%d",&n,&m,&k);
    while(m--) {
        int u,v;
        scanf("%d%d",&u,&v);
        g[u].push_back(v);
        g[v].push_back(u);
    }
    while(k--) {
        int x,cnt=0;
        init(n);
        scanf("%d",&x);
        vis[x]=1;
        for(int i=1; i<=n; i++) {
            if(!vis[i]) {
                dfs(i);
                cnt++;
            }
        }
        printf("%d\n",cnt-1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/81000500