PAT 1013 Battle Over Cities (25 分)

1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.For example, if we have 3 cities and 2 highways connecting c i t y 1 city_1 - c i t y 2 city_2 and c i t y 1 city_1 - c i t y 3 city_3 . Then if c i t y 1 city_1 is occupied by the enemy, we must have 1 highway repaired, that is the highway c i t y 2 city_2- city_3$.


Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.


Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0




解析

#include<cstdio>
#include<vector>
#include<algorithm>
#include<iterator>
using namespace std;
const int MAXN = 1001;
vector<vector<int>> G;
bool vis[MAXN]{false};
void DFS(int node) {
	vis[node] = true;
	for (auto x : G[node])
		if (vis[x] == false)
			DFS(x);
}
int DFSTraver(int lost) {
	fill(begin(vis), end(vis), false);
	vis[lost] = true;
	int block = 0;
	for (int i = 1; i < G.size(); i++) {
		if (vis[i] == false) {
			block++;
			DFS(i);
		}
	}
	return block-1;
}
int main()
{
	int N, M, K;
	scanf("%d %d %d", &N, &M, &K);
	G.resize(N + 1);  // 1~N
	int city1, city2;
	for (int i = 0; i < M; i++) {
		scanf("%d %d", &city1, &city2);
		G[city1].push_back(city2);
		G[city2].push_back(city1);
	}
	int query;
	for (int i = 0; i < K; i++) {
		scanf("%d", &query);
		printf("%d\n",DFSTraver(query));
	}
}
/*
N (<1000), M and K
3 2 3
1 2
1 3
1 2 3

*/

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/84753104