PAT甲级1013 Battle Over Cities------图的遍历

题目描述:

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city ​1 ​​ -city ​2 ​​ and city ​1 ​​ -city ​3 ​​ . Then if city ​1 ​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city ​2 ​​ -city ​3 ​​ .

Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:
3 2 3
1 2
1 3
1 2 3
Sample Output:
1
0
0

题目大意:
题目中说的是,要加几条边才能重新连接起来,就是要找出来有多少个连通分量,修复公路的数就等于连通分量数-1。求连通分量就涉及到图的遍历,感觉DFS写起来跟简单一些。

代码如下:

#include <iostream>
#include<algorithm>
using namespace std;
int edge[1000][1000]={0},flag[1000],n;
void DFS(int i)
{
    flag[i]=1;
    for(int j=1;j<n+1;j++){
        if(edge[i][j]&&!flag[j]) DFS(j);
    }
}
int main()
{
    int m,k,a,b;
    scanf("%d%d%d",&n,&m,&k);
    for(int i=0;i<m;i++){
        scanf("%d%d",&a,&b);
        edge[a][b]=edge[b][a]=1;
    }
    while(k--){
        fill(flag,flag+1000,0);
        int count=0;
        scanf("%d",&a);
        flag[a]=1;
        for(int i=1;i<n+1;i++)
            if(!flag[i]) {
                count++;
                DFS(i);
            }
        printf("%d\n",count-1);
    }
    return 0;
}

来总结一下:
1)这个题刚开始我还构造了另外一个数组,用来存储每一次检查时(就是去掉了一个边时)的邻接矩阵,后来发现,只要将该点加入集合(flag),就可以不会再访问到和该点有关的值。

2)本来最后一个测时点一直超时,后来将所有的cin和cout都换成scanf和printf后就AC了。

猜你喜欢

转载自blog.csdn.net/sun9979/article/details/86664266