hdu2026 01背包输出最优方案数

Buy the souvenirs

Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3357    Accepted Submission(s): 1313


 

Problem Description

When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few. So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance:



And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7), ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10).

 

Input

For the first line, there is a T means the number cases, then T cases follow.
In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir. 
All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.

 

扫描二维码关注公众号,回复: 5802840 查看本文章

Output

If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can't buy anything.”

 

Sample Input

 

2 4 7 1 2 3 4 4 0 1 2 3 4

 

Sample Output

 

You have 2 selection(s) to buy with 3 kind(s) of souvenirs. Sorry, you can't buy anything.

 

Author

wangye

 

Source

HDU 2007-10 Programming Contest

 

Recommend

威士忌   |   We have carefully selected several similar problems for you:  2128 2129 2130 2125 2124 

 

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define maxn 105
#define maxm 1005
using namespace std;
int dp[2][maxm];
int w[maxn];
int n,m;
int t;
int main()
{scanf("%d",&t);
    while(t--)
{scanf("%d%d",&n,&m);
    memset(dp,0,sizeof(dp));
    for(int i=0;i<=maxm;i++)
dp[1][i]=1;

    for(int i=1;i<=n;i++)
        scanf("%d",&w[i]);
        for(int i=1;i<=n;i++)
            for(int v=m;v>=w[i];v--)
        {
            if(dp[0][v]<dp[0][v-w[i]]+1)
            {dp[0][v]=dp[0][v-w[i]]+1;
            dp[1][v]=dp[1][v-w[i]];

            }
             else if(dp[0][v]==dp[0][v-w[i]]+1)
            {
                dp[1][v]+=dp[1][v-w[i]];
            }
        }
        if(dp[0][m])
            printf("You have %d selection(s) to buy with %d kind(s) of souvenirs.\n",dp[1][m],dp[0][m]);
        else
            printf("Sorry, you can't buy anything.\n");
}
return 0;

}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/89059870
今日推荐