POJ 3067 Japan

http://poj.org/problem?id=3067

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;

const int maxn = 1e6 + 10;
int T, N, M, K;
int c[maxn];

struct Node{
    int x;
    int y;
}node[maxn];

bool cmp(const Node &a, const Node &b) {
    if(a.x != b.x)
        return a.x < b.x;
    return a.y < b.y;
}

int lowbit(int x) {
    return x & (-x);
}

void add(int i, int val) {
    while(i <= M) {
        c[i] += val;
        i += lowbit(i);
    }
}

int getsum(int x) {
    int ans = 0;
    while(x > 0) {
        ans += c[x];
        x -= lowbit(x);
    }
    return ans;
}

int main() {
    scanf("%d", &T);
    for(int t = 1; t <= T; t ++) {
        memset(c, 0, sizeof(c));
        scanf("%d%d%d", &N, &M, &K);

        for(int i = 1; i <= K; i ++)
            scanf("%d%d", &node[i].x, &node[i].y);

        sort(node + 1, node + 1 + K, cmp);

        long long ans = 0;
        for(int i = 1; i <= K; i ++) {
            printf("!!!%d\n", getsum(M));
            ans += getsum(M) - getsum(node[i].y);
            add(node[i].y, 1);
        }


        printf("Test case %d: %lld\n", t, ans);
    }
    return 0;
}

  树状数组求逆序对

所有美好的事情都应该有回音

猜你喜欢

转载自www.cnblogs.com/zlrrrr/p/10661058.html