poj3067 japan

http://poj.org/problem?id=3067

Japan

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 31876   Accepted: 8564

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

emmmmmm刚开始学树状数组,之前写过板子,用了一只超时,心态爆炸啊,最后发现卡输入输出...........思路是一边城市先排序,另一边城市建一个树状数组,只要发现后面有前面的城市就有交叉。

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
const int maxn =1003;
using namespace std;
int c[maxn];
int n,m,k;
struct node
{
	int l;
	int r;
}ac[1003*1002];
bool cmp(node a,node b)
{
	if(a.l==b.l)return a.r<=b.r;
    else return a.l<b.l;
}
int lowerbit(int y)
{
	return y&(-y);
}
void btree(int x)
{
	for(int i=x;i<=m;i+=lowerbit(i))
	{
		c[i]+=1;
	}
//	return x;
}
int querty(int z)
{
	long long ans=0;
	for(int i=z;i>0;i-=lowerbit(i))
	{
		ans+=c[i];
	}
	return ans;
}
int main()
{
	int T,sum=0;
	cin>>T;
	while(T--)
	{
		scanf("%d%d%d",&n,&m,&k);
		for(int i=0;i<k;i++)
		{
			scanf("%d%d",&ac[i].l,&ac[i].r);
		}
		sort(ac,ac+k,cmp);
		memset(c,0,sizeof(c));
		long long ans=0;
		for(int i=0;i<k;i++)
		{
			btree(ac[i].r);
			ans+=querty(m)-querty(ac[i].r);
		}
			sum++;
		printf("Test case %d: %lld\n",sum,ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41453511/article/details/81200673