poj--3067 Japan (树状数组) ʕ •ᴥ•ʔ

Japan

Time Limit: 1 Sec  

Memory Limit: 256 MB

题目连接

http://acm.uestc.edu.cn/#/problem/show/383

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (1≤M≤10000, 1≤N≤10000). K superhighways will be build.(1≤K≤1000000) Cities on each coast are numbered 1,2,⋯ from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

HINT

题意

 左边有n个城市,右边有m个城市,然后连了k条线,问你一共有多少个交点

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
#define N 100100
#include<map>
#define ll long long 
using namespace std;
int n,m,q;
struct ac
{
	int s,e;
}r[1010000];// 这里数组要开大点 
int a[1010];
//  先按结束点排序  结束点大的放在前面   
//  如果结束点相同  按照开始点排序  开始点大的放前面 
int cmp(ac x,ac y)
{
	if(x.e!=y.e)
	return x.e>y.e;
	else
	return x.s>y.s;
}

//树状数组模板 
int lowbit(int w)
{
	return w&-w;
}
int sum(int w)
{
	int ans=0;
	while(w>0)
	{
		ans+=a[w];
		w-=lowbit(w);
	}
	return ans;
}
int add(int w)
{
	while(w<1010)
	{
		a[w]++;
		w+=lowbit(w);
	}
} 
int main()
{
	int t;
	scanf("%d",&t);
	int z=1;
	while(t--)
	{
		scanf("%d%d%d",&n,&m,&q);
		memset(a,0,sizeof(a));
		for(int i=0;i<q;i++)
		{
			scanf("%d%d",&r[i].s,&r[i].e);
		}
		sort(r,r+q,cmp);//关键 
		ll ans=0;
		for(int i=0;i<q;i++)
		{
			ans+=sum(r[i].s-1);//因为要求交叉点的数量 所以我们需要 -1 
			add(r[i].s);
		} 
		printf("Test case %d: %lld\n",z++,ans);
	}
	return 0;
	
} 

猜你喜欢

转载自blog.csdn.net/henucm/article/details/81475074