ICPC 2017 Japan Tsukuba . Medical Checkup(思维)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/XxxxxM1/article/details/82263368

问题 C: Medical Checkup

时间限制: 2 Sec  内存限制: 128 MB
提交: 199  解决: 58
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Students of the university have to go for a medical checkup, consisting of lots of checkup items,numbered 1, 2, 3, and so on.
Students are now forming a long queue, waiting for the checkup to start. Students are also numbered 1, 2, 3, and so on, from the top of the queue. They have to undergo checkup items in the order of the item numbers, not skipping any of them nor changing the order. The order of students should not be changed either.
Multiple checkup items can be carried out in parallel, but each item can be carried out for only one student at a time. Students have to wait in queues of their next checkup items until all the others before them finish.
Each of the students is associated with an integer value called health condition. For a student with the health condition h, it takes h minutes to finish each of the checkup items. You may assume that no interval is needed between two students on the same checkup item or two checkup items for a single student. 
Your task is to find the items students are being checked up or waiting for at a specified time t.

输入

The input consists of a single test case in the following format.
n t
h1
.
.
.
hn
n and t are integers. n is the number of the students (1 ≤ n ≤ 105). t specifies the time of our concern (0 ≤ t ≤ 109). For each i, the integer hi is the health condition of student i(1 ≤ hi ≤ 109).

输出

Output n lines each containing a single integer. The i-th line should contain the checkup item number of the item which the student i is being checked up or is waiting for, at (t+0.5) minutes after the checkup starts. You may assume that all the students are yet to finish some of the checkup items at that moment.

样例输入

3 20
5
7
3

样例输出

5
3
2
#include<bits/stdc++.h>
using namespace std;
#define ll long long
 
int main()
{
    ll n,t;
    while(cin>>n>>t)
    {
        ll cnt=0,m=-1,q;
        for(int i=0; i<n; i++)
        {
            cin>>q;
            m=max(m,q);
            cnt+=q;
            if(t>=cnt)cout<<(t-cnt)/m+2<<endl;
            else
                cout<<1<<endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/XxxxxM1/article/details/82263368