POJ 3067 Japan 树状数组求逆序数

可以发现规律,用树状数组,求逆序数之和,累加sum(MAXN)-sum(nodes[i].x);

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int MAXN=1000;
const int MAXM=1000000+1000;
int c[MAXN+1];//c[0]是无效的
struct node
{
    int x,y;
    bool operator <(const node &b)const
    {
        return y<b.y||( y==b.y&&x<b.x );
    }
}nodes[MAXM];
int lowbit(int x)
{
    return x&(-x);
}
int sum(int x)
{
    int res=0;
    while(x>0)
    {
        res +=c[x];
        x-=lowbit(x);
    }
    return res;
}
void add(int x,int v)
{
    while(x<=MAXN)
    {
        c[x]+=v;
        x+=lowbit(x);
    }
}
int main()
{
    int T,kase=1;
    scanf("%d",&T);
    while(T--)
    {
        int n,m,k;
        scanf("%d%d%d",&n,&m,&k);
        for(int i=0;i<k;i++)
            scanf("%d%d",&nodes[i].x,&nodes[i].y);
        sort(nodes,nodes+k);
        memset(c,0,sizeof(c));
        long long ans=0;
        for(int i=0;i<k;i++)
        {
            add(nodes[i].x,1);
            //找它的逆序数,而sum(MAXN)-sum(nodes[i].x)就是逆序数;
            ans += sum(MAXN)-sum(nodes[i].x);//累加逆
        }
        printf("Test case %d: %I64d\n",kase++,ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/86308547