A - Bi-shoe and Phi-shoe LightOJ - 1370

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题目大意:就是最小的欧拉函数值;欧拉函数值就是小于或等于n的正整数中与n互质的数的数目;

解题思路:我们知道一个素数P的欧拉函数值ψ(P)=P-1。所以如果我们知道ψ(N),那么最小的N就是最接近ψ(N),

并且大于ψ(N)的素数。然后我们用欧拉筛打表算出最小值即可;

代码:

#include<stdio.h>
int a[1010011]= {0};
int b[1010011]= {0};
int main()
{

    int t=0,m;
    a[0]=1;
    a[1]=1;
    int i,j;
    for(i=2; i<=1010100; i++)  //用欧拉筛打素数表
    {
        if(!a[i]) b[t++]=i;
        for(j=0; j<t; j++)
        {
            if(i*b[j]>1010101)
                break;
            a[i*b[j]]=1;
            if(i%b[j]==0)
                break;
        }
    }
    t=0;
    for(i=1; i<=1000001; i++)  //
    {
        if(i<b[t]) a[i]=b[t];  //比素数小就是最小的素数
        else
        {
            t++;
            a[i]=b[t];        //大于这个数的最小素数
        }
    }
    int n,k=1;
    scanf("%d",&n);
    while(n--)
    {
        int m;
        scanf("%d",&m);
        long long  int sum=0;
        int d;
        for(i=0; i<m; i++)
        {
            scanf("%d",&d);  //直接加上打好的表就行了
            sum+=a[d];
        }
        printf("Case %d: %lld Xukha\n",k++,sum);
    }
    return 0;

}

猜你喜欢

转载自blog.csdn.net/TANG3223/article/details/82318486
今日推荐