LightOJ - 1370 Bi-shoe and Phi-shoe(素数筛选法)

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo’s length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output
For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input
3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output
Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

如果每个数都做为欧拉函数的值的话,那这个数最小就是大于这个值的素数;
例如:1~2,2~3,3~5,4~5,5~7,6~7……
故想到用素数打表就可以实现:

主要思路:素数筛选

先设置a[MAXN]做为标记数组;先将a[1]标记为1,从2开始,如果2不为1,将2的倍数标为1,
如此循环:
2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20…….
2,3,5,7,9,11,13,15,17,19,,,,,,
2,3,5,7,11,13,19,,,,,,
最后筛选下来的都是素数;可以在其中将素数储存在另个数组(打表)**

最后注意,%I64d 与%lld的使用,该用%lld时用另一个会直接导致代码出错
代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long ll;
const ll MAXN = 1000005;
ll a[MAXN],b[MAXN];
ll t,n,sum;
int T;
void su()
{
    memset(a,0,sizeof(a));
    a[1] = 1,t=1;
    for(ll i=2;i<MAXN;i++)
    {
        if(!a[i]){//每个素数作为头
            while(t<i) //打表
            {
                b[t] = i;
                t++;
            }
            for(ll j=2*i;j<MAXN;j+=i)//一直查找素数头的倍数并标记
            {   
                if(!a[j])
                a[j] = 1;
            }
        } 
    }
}
int main()
{
    su();
    scanf("%d",&T);
    for(int i=1;i<=T;i++)
    {
        scanf("%lld",&n);
        sum = 0;
        for(ll j=1;j<=n;j++)
        {
            int z;
            scanf("%d",&z);
            sum += b[z];
        }
        printf("Case %d: %lld Xukha\n",i,sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/orange1710/article/details/81488430
今日推荐