LightOJ - 1370 Bi-shoe and Phi-shoe (素数筛&欧拉)

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo’s length)

(Xzhilans are really fond of number theory). For your information, Φ ( n ) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input
Input starts with an integer T ( 100 ) , denoting the number of test cases.

Each case starts with a line containing an integer n ( 1 n 10000 ) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output
For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input
3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1
Sample Output
Case 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha

题意: 每个学生所得的bamboo的score的值必须大于或等于他的幸运数字, bamboo的score值就是其长度x的欧拉函数值(即小于x且与x互质的数的个数)
每单位长度花费1Xukha,求买这些bamboo的最小花费。
解题思路:对于素数来说,其欧拉函数值等于他自身减一,所以对于一个幸运数字,它后面的那一个素数的欧拉函数值一定是大于或等于幸运数字的,所以最小花费就是幸运数字的后面一个素数之的和

#include<iostream>
#include<cstdio>
#include<cstring> 
#include<algorithm>
#include<cmath>
#include<vector>
#include<deque>
#include<queue>
#include<ctime>
#define INF 0x3f3f3f3f
using namespace std;

int mp[1000005];

int main(){
    for(int i=1; i<1000005; i++){
        mp[i] = i;
    }
    //素数筛,筛选素数
    for(int i=2; i<1000005; i++){
        if(mp[i]){
            for(int j=i+i; j<1000003; j+=i){
                mp[j] = 0;
            }
        }
    }
    int count = 1000003;//输入要求内的最大值
    //在当前位置补充下一位素数的值
    for(int i=1000000; i>=0; i--){
        if(mp[i] == 0) mp[i] = count;
        else {
            int temp = mp[i];
            mp[i] = count;
            count = temp;
        }
    }
    int n;
    int cent = 1;
    scanf("%d",&n);
    while(n--){
        int m;
        scanf("%d",&m);
        int x;
        long long int sum = 0;
        for(int i=0; i<m; i++){
            scanf("%d",&x);
            sum += mp[x];
        }
        printf("Case %d: %lld Xukha\n",cent++,sum);
    }
}

猜你喜欢

转载自blog.csdn.net/qinying001/article/details/82382581
今日推荐