LightOJ-1370 Bi-shoe and Phi-shoe (筛法欧拉函数)

LightOJ-1370 Bi-shoe and Phi-shoe (筛法欧拉函数)

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int euler[3000001];
void getEuler()
{
   memset(euler,0,sizeof(euler));
   euler[1] = 1;
   for(int i = 2;i <= 3000000;i++)
   if(!euler[i])
   for(int j = i;j <= 3000000; j += i)
   {
    if(!euler[j])
    euler[j] = j;
    euler[j] = euler[j]/i*(i-1);
   }
}
//这步最终就是存的是j的欧拉函数的值
int main()
{
    int t,n,i;
    int cas=0;
    getEuler();
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        long long sum=0;
        for(i=0;i<n;i++)
        {
            int a;
            scanf("%d",&a);   //一个数的欧拉值是a,那么他至少从a+1开始,因为不包括自己
            int x=a+1;        
            while(euler[x]<a)
            x++;
            sum+=x;
        }
        printf("Case %d: %lld Xukha\n",++cas,sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xigongdali/article/details/80460963
今日推荐