HDU - 1874 畅通工程续 (链式前向星+优先队列+dijkstra)

某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。 

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。

Input

本题目包含多组数据,请处理到文件结束。 
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。 
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。 
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。

Output

对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.

Sample Input

3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2

Sample Output

2
-1

解题思路:dijkstra模板题

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>

using namespace std;

const int maxn=2100;
const int INF=0x3f3f3f3f;

struct node{
	int to;
	int w;
	int next;
}e[maxn];

struct test{
	int u;
	int dis;
	bool friend operator <(test a,test b)
	{
		return a.dis>b.dis;
	}
}term,nextt;
int head[maxn],cnt,n,m;

int d[maxn],vis[maxn];

void add(int u,int to,int w)
{
	e[cnt].to=to;
	e[cnt].w=w;
	e[cnt].next=head[u];
	head[u]=cnt++;
} 

void dijkstra_heap(int u,int t)
{
	d[u]=0;
	priority_queue<test> q;
	term.u=u;
	term.dis=d[u];
	q.push(term);
	while(!q.empty())
	{
		term=q.top();
		q.pop();
		vis[term.u]=1;
		for(int i=head[term.u];~i;i=e[i].next)
		{
			int to=e[i].to;
			int w=e[i].w;
			if(!vis[to]&&d[term.u]+w<d[to])
			{
				d[to]=d[term.u]+w;
				nextt.u=to;
				nextt.dis=d[to];
				q.push(nextt);
			}
		}
	}
}
int main()
{
	int u,v,w,s,t;
	while(~scanf("%d%d",&n,&m))
	{
		memset(head,-1,sizeof(head));
		memset(vis,0,sizeof(vis));
		memset(d,INF,sizeof(d));
		cnt=0;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d%d",&u,&v,&w);
			add(u,v,w);
			add(v,u,w);
		}
		scanf("%d%d",&s,&t);
		dijkstra_heap(s,t);
		if(d[t]!=INF)
			printf("%d\n",d[t]);
		else
			printf("-1\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40707370/article/details/88658768