PTA-1107 Social Clusters (30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki​​: hi​​[1] hi​​[2] ... hi​​[Ki​​]

where Ki​​ (>) is the number of hobbies, and [ is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

思路:

有n个人,每个人喜欢k个活动,如果两个人有任意一个活动相同,就称为他们处于同一个社交网络。求这n个人一共形成了多少个社交网络。

 
#include <bits/stdc++.h>
using namespace std;
int p[10010],a[10010];
int n,k,m,h;
char c;
bool cmp(int a,int b)
{
    return a>b;
}

int found(int x)
{
    if(p[x] == x)
        return x;
    return found(p[x]);
}//found函数返回的是
void unite(int a,int b)
{
    int x = found(a);
    int y = found(b);
    if(x!=y)
    {
        p[y] = x;
    }
}//unite函数
int main()
{
    scanf("%d",&n);
    for(int i=0;i<=n;i++)
        p[i] = i;
    for(int i=1;i<=n;i++)
    {
        scanf("%d %c",&k,&c);
        for(int j=1;j<=k;j++)
        {
            scanf("%d",&h);
            if(a[h] == 0)
            {
                a[h] = i;
            }
            else
            {
                unite(found(a[h]),i);
            }
        }
    }
    int cnt = 0;
    int count1[1010] = {0};
    for(int i=1;i<=n;i++)
    {
        count1[found(i)]++;
    }
    for(int i=1;i<=n;i++)
    {
        if(count1[i]!=0)
            cnt++;
    }
    cout<<cnt<<endl;
    sort(count1+1,count1+n+1,cmp);
    for(int i=1;i<=cnt;i++)
    {
        if(i==1)
            cout<<count1[i];
        else
            cout<<" "<<count1[i];
    }
    return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/tonyyy/p/10544331.html