1107 Social Clusters (30 分)(并查集)

1107 Social Clusters (30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

题目意思:就是求只要有一个爱好相同的人 就是一堆 求有多少堆

思想: 我把每个人都弄一个表示 它的代表爱好是。。。。

又弄一个数组来表示每个爱好相关的是。。。

然后输出

代码:

#include<bits/stdc++.h>
using namespace std;
int pre[1005], box[1005];
int find(int x){
	if ( x == box[x])
		return x;
	else
		return box[x] = find(box[x]);
}
void merge(int x, int y){
	int fx = find(x);
	int fy = find(y);
	if(fx != fy)
		box[fx] = fy;
	return ;
}
bool cmp(int a, int b){
	return a > b;
}
int main()
{
	int n, k, x, y;
	for(int i  = 1 ; i <= 1000 ; i ++)
		pre[i] = i , box[i] = i; //初始化人的
	
	scanf("%d",&n);	
	for(int i = 1 ; i <= n; i ++)
	{
		scanf("%d:", &k);
		scanf("%d",&x);
		pre[i] = x;
		for(int j = 2; j <= k; j ++)
		{
			scanf("%d", &y); 
			merge(x,y);
		}
	}
	int ans[1005] = {0};
	for(int i  = 1; i <= n; i ++)
		ans[find(pre[i])] ++;
	vector<int>vec;
	for(int i = 1; i <= 1000; i++){
		if(ans[i] != 0){
			vec.push_back(ans[i]);
		}
	}
	sort(vec.begin(),vec.end(),cmp);
	int size = vec.size();
	printf("%d\n",size);
	for(int i = 0 ; i < size; i ++){
		printf("%d%c",vec[i]," \n"[i == size - 1]);
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/84201388
今日推荐