PAT甲级 1107 Social Clusters (30 分)并查集

1107 Social Clusters (30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

解题思路: 该题简单,主要是利用并查集将人分成几个组。最后输出组数与每个组对应的人数即可。

#include <iostream>
#include <cstdio>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;

vector<int> f(10001);

int find(int node){
	int x = node;
	while(f[x]!=x)
		x = f[x];
	int i = node,temp;
	while(f[i]!=x){//剪枝 
		temp = f[i];
		f[i] = x;
		i = temp;
	}
	return x;
}

void unio(int a,int b){
	int fa = find(a),fb = find(b);
	if(fa != fb)
		f[fa] = fb;
} 

bool cmp(int a,int b){
	return a > b;
}

int main(){
	int n,a,b;
	cin>>n;
	for(int i=1;i<10001;i++)
		f[i] = i;
	vector<int> person[n],vec,vst(10001,0),ans;
	for(int i=0;i<n;i++){
		scanf("%d: ",&a);
		for(int j=0;j<a;j++){
			cin>>b;
			person[i].push_back(b);
			vec.push_back(b);
		}	
		for(int j=0;j<person[i].size()-1;j++)
			unio(person[i][j],person[i][j+1]);
	}
	for(int i=0;i<vec.size();i++)
		find(vec[i]);
	int cnt = 0;
	map<int,int> mp;
	for(int i=0;i<vec.size();i++){
		if(vst[f[vec[i]]] == 0){
			vst[f[vec[i]]] = 1;
			cnt++;
		}
	}
	cout<<cnt<<endl;
	for(int i=0;i<n;i++){
		int index = f[person[i][0]];//找到每个人对应的小组 
		mp[index]++;//记录小组对应的人数 
	}
	for(auto it:mp)
		ans.push_back(it.second);
	sort(ans.begin(),ans.end(),cmp);
	for(int i=0;i<ans.size();i++)
		printf("%d%s",ans[i],i!=ans.size()-1?" ":"");		
		
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/85344604
今日推荐