PAT甲级--1107 Social Clusters(30 分)【并查集】

1107 Social Clusters(30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

解题思路:这题是用并查集,我们用course记录课程第一次出现的人的编号,然后后面的人出现的人的编号跟这个课程第一次出现的人的编号Combine一下就好了,然后我们就从1到n去找是集合的代表元并加1,然后我们再从1到n中看一下加的数量,如果数量不为0,就说明是一个圈,然后我们要统计有多少个圈,然后根据题目要求,从大到小排序,然后输出答案就好。(并查集可以看看https://blog.csdn.net/Imagirl1/article/details/82353349)。

#include<bits/stdc++.h>
using namespace std;
vector<int>father,isroot;
//并查集
int find(int x)
{
	while(x!=father[x])
	x=father[x];
	return x;
}
void Combine(int a,int b)
{
	int fa1=find(a);
	int fa2=find(b);
	if(fa1!=fa2)
	father[fa1]=fa2;
}

bool cmp(int a,int b)
{
	return a>b;
}
int main(void)
{
	int n,m;
	scanf("%d",&n);
	int course[1001]={0};//初始化为0
	isroot.resize(n+1);//统计最父亲节点的人数的数量
	father.resize(n+1);
	for(int i=1;i<=n;i++)
	{
		father[i]=i;//都初始化为自己
	}
	for(int i=1;i<=n;i++)
	{
		scanf("%d:",&m);
		int t;
		for(int j=0;j<m;j++)
		{
			scanf("%d",&t);
			if(course[t]==0 )
			course[t]=i;//course[t]不会变,永远都是第一次出现的位置
			Combine(i,course[t]); //合并
		}
	}
	for(int i=1;i<=n;i++)
	{
		isroot[find(i)]++;//找到最父亲的节点并加一
	}
	int cnt=0;
	for(int i=1;i<=n;i++)
	{
		if(isroot[i]!=0) cnt++;//统计有多少个圈
	}
	printf("%d\n",cnt);
	sort(isroot.begin(),isroot.end(),cmp);
	for(int i=0;i<cnt;i++)
	{
		printf("%d",isroot[i]);
		if(i!=cnt-1) printf(" ");
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82388543
今日推荐