PAT 1107.Social Clusters(30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1
#include <stdio.h>
#include <vector>
#include <algorithm>
#define maxsize 1001
using namespace std;
vector<int> root;
int findRoot(int x)
{
    if(root[x] == -1)
        return x;
    else{
        int temp= findRoot(root[x]);
        root[x] =temp;
        return temp;
    }
}
int cmp(int x,int y)
{
    return x>y;
}
int main()
{
    int n,k;
    scanf("%d",&n);
    root.resize(n+maxsize,-1);
    vector<int> sum(n+maxsize,1);
    for(int i=0;i<n;i++)
    {
        scanf("%d:",&k);
        for(int j=0;j<k;j++)
        {
            int a;
            scanf(" %d",&a);
            a=findRoot(a);
            root[a]=i+maxsize;
        }
    }
    int cnt=0;
    for(int i=maxsize;i<n+maxsize;i++)
    {
        if(root[i]==-1)
        {
            cnt++;
        }
    }
    vector<int> add(cnt,1);
    int t=0;
    for(int i=maxsize;i<n+maxsize;i++)
    {
        if(root[i] == -1){
            for(int j=maxsize;j<n+maxsize;j++){
                if(i==j) continue;
                int aRoot = findRoot(j);
                if(aRoot == i)
                {
                    add[t] += 1;
                }

            }
            t++;
        }
    }
    printf("%d\n",cnt);
    sort(add.begin(),add.end(),cmp);
    for(int i=0;i<cnt;i++)
    {
        if(i!=0)
            printf(" ");
        printf("%d",add[i]);
    }
    printf("\n");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sinat_32676193/article/details/82421180