1107 Social Clusters (30 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/acm_zh/article/details/88061357

1107 Social Clusters (30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1
#include<iostream>
#include<string>
#include<vector>
#include<cstdio>
#include<algorithm>
using namespace std;
int f[1001];
vector<int> book(1001);
vector<int> root;
int getf(int x){
	while(f[x] != x){
		x = f[x];
	}
	return x;
}
void merge(int x,int y){
	int t1 = getf(x);
	int t2 = getf(y);
	if(t1 != t2)
		f[t1] = t2;
}
int cmp(int a,int b){
	return a > b;
}
int main(){
	int n;
	cin >> n;
	for(int i = 0;i < 1001;i++){
		f[i] = i;
	}
	root.resize(n+1);
	for(int i = 1;i <= n;i++){
		int k;
		scanf("%d:",&k);
		for(int j = 1;j <= k;j++){
			int a;
			cin >> a;
			if(book[a] == 0)
				book[a] = i;
			merge(i,getf(book[a]));
		}
	}
	for(int i = 1;i <= n;i++){
		root[getf(i)]++;
	}
	int ans = 0;
	for(int i = 1;i <= n;i++){
		if(root[i]!=0)
			ans++;
	}
	cout << ans << endl;
	sort(root.begin(),root.end(),cmp);
	for(int i = 0;i < ans;i++){
		cout << root[i];
		if(i != ans-1) cout << " ";
	}
	return 0;
	
	
} 

猜你喜欢

转载自blog.csdn.net/acm_zh/article/details/88061357
今日推荐