1107 Social Clusters(30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1
#include<cstdio>
#include<algorithm>
#include<fstream>
using namespace std;
const int maxn=1010;

int father[maxn];
int course[maxn]={0};
int isroot[maxn]={0};

void init(int n){
	for(int i=1; i<=n; i++){
		father[i]=i;
		isroot[i]=false;
	}	
}

int findfather(int x){
	while(x!=father[x]){
		x=father[x];
	}
	return x;
}

void Union(int a, int b){
	int faA=findfather(a);
	int faB=findfather(b);
	if(faA!=faB){
		father[faA]=faB;
	}
}

bool cmp(int a, int b){
	return a>b;
}

int main(){
	int n, k, h;
//	freopen("d://in.txt","r",stdin);
	scanf("%d", &n);
	init(n);
	for(int i=1; i<=n; i++){
		scanf("%d:", &k);
		for(int j=0; j<k; j++){
			scanf("%d", &h);
			if(course[h]==0){
				course[h]=i;
			}
			Union(i, findfather(course[h]));
		}
	}
	for(int i=1; i<=n; i++){
		isroot[findfather(i)]++;
	}
	int ans=0;
	for(int i=1; i<=n; i++){
		if(isroot[i]!=0){
			ans++;
		}
	}
	printf("%d\n", ans);
	sort(isroot+1, isroot+n, cmp);
	for(int i=1; i<=ans; i++){
		printf("%d", isroot[i]);
		if(i<ans) printf(" ");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Chuyuan_li/article/details/81669581