PAT A1041

  • 题目:
    Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.
    Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.
Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.
Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

  • 分析
    题目大意: 给出一系列1~10000的整数,从中找到第一个出现一次的数。若可以找到这样的数,则输出此数;否则,则输出None;

解题思路:
1.数组map1存放每个输出数字的出现次数,初始值为0;
2.query数组按照输入顺序存放数字,并作为map1的下标,可以让map1按照输入顺序查看每个数字出现的次数

代码实现:

扫描二维码关注公众号,回复: 5777812 查看本文章
#include <cstdio>
int Hash[10010] = {0}, A[100001];
int main()
{
    int n;
    scanf("%d", &n);
    for(int i = 0; i < n; i++){
        scanf("%d", &A[i]);
        Hash[A[i]]++;
    }
    for(int i = 0; i < n; i++){
        if(Hash[A[i]] == 1){
           printf("%d", A[i]);
           return 0;
        }
    }
    printf("None");
    return 0;
}


猜你喜欢

转载自blog.csdn.net/xiao1guaishou/article/details/88925429
今日推荐