PAT_甲级_1012

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/lzc842650834/article/details/87914096

1012 The Best Rank

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

这题思路不难,却十分繁琐。写的整体思路没问题,但有三个测试点都过不去,先放这,改日再战。

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct info{
    int id;
    int C_grade;
    int C_level;
    int M_grade;
    int M_level;
    int E_grade;
    int E_level;
    int ave_grade;
    int ave_level;
}stu[2001];
int flag[10000000] = {0};

bool cmp_C(struct info a,struct info b)
{
    return a.C_grade > b.C_grade;
}
bool cmp_M(struct info a,struct info b)
{
    return a.M_grade > b.M_grade;
}
bool cmp_E(struct info a,struct info b)
{
    return a.E_grade > b.E_grade;
}
bool cmp_ave(struct info a,struct info b)
{
    return a.ave_grade > b.ave_grade;
}
int main()
{
    int m, n;
    cin >> m >> n;
    for (int i = 0; i < m; i++) {
        cin >> stu[i].id >> stu[i].C_grade >> stu[i].M_grade >> stu[i].E_grade;
        flag[stu[i].id] = 1;
        stu[i].ave_grade = (stu[i].C_grade + stu[i].M_grade + stu[i].E_grade);
    }
    sort(stu, stu + m, cmp_C);
    for (int i = 0; i < m; i++) {
        stu[i].C_level = i + 1;
        cout << stu[i].id << "C_level" <<' ' << stu[i].C_level << endl;
    }
    for (int i = 1; i < m; i++) {
        if (stu[i].C_grade == stu[i - 1].C_grade) {
            stu[i].C_level = stu[i - 1].C_level;
        }
    }
    sort(stu, stu + m, cmp_M);
    for (int i = 0; i < m; i++) {
        stu[i].M_level = i + 1;
    }
    for (int i = 1; i < m; i++) {
        if (stu[i].M_grade == stu[i - 1].M_grade) {
            stu[i].M_level = stu[i - 1].M_level;
        }
    }
    sort(stu, stu + m, cmp_E);
    for (int i = 0; i < m; i++) {
        stu[i].E_level = i + 1;
    }
    for (int i = 1; i < m; i++) {
        if (stu[i].E_grade == stu[i - 1].E_grade) {
            stu[i].E_level = stu[i - 1].E_level;
        }
    }
    sort(stu, stu + m, cmp_ave);
    for (int i = 0; i < m; i++) {
        stu[i].ave_level = i + 1;
    }
    for (int i = 1; i < m; i++) {
        if (stu[i].ave_grade == stu[i - 1].ave_grade) {
            stu[i].ave_level = stu[i - 1].ave_level;
        }
    }
    int id_temp;
    for (int i = 0; i < n; i++) {
        cin >> id_temp;
        if (flag[id_temp] == 0) {
            cout << "N/A" << endl;
        } else {
            for (int i = 0; i < n; i++) {
                int level_min = 100000000;
                char kind = 'A';
                if (stu[i].id == id_temp) {
                    level_min = stu[i].ave_level;
                    if (stu[i].C_level < level_min) {
                        kind = 'C';
                        level_min = stu[i].C_level;
                    }
                    if (stu[i].M_level < level_min) {
                        kind = 'M';
                        level_min = stu[i].M_level;
                    }
                    if (stu[i].E_level < level_min) {
                        kind = 'E';
                        level_min = stu[i].E_level;
                    }
                    cout << level_min << ' ' << kind << endl;
                    continue;
                }
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lzc842650834/article/details/87914096