PAT 甲级练习 1012

1012. The Best Rank

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output “N/A”.
Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A

代码如下:

#include <iostream>
#include <vector>
#include <iterator>
#include <map>
#include <algorithm>

using namespace std;

char n2s[4] = {'C', 'M', 'E', 'A'};
vector<char> num2subjet(n2s, n2s+4);

struct Student{
    int number;
    int grade[4], rank[4];

    Student(){}
    Student(int n, int c, int m, int e):number(n) {
        grade[0] = c, grade[1] = m, grade[2] = e,
        grade[3] = 1.0*(c + m + e)/3 + 0.5;
    }

    pair<int, char> best_rank(){
        int rk = rank[3];
        char subject = 'A';
        for(int i=0; i<3; ++i){
            if(rank[i] < rk){
                rk = rank[i];
                subject = num2subjet[i];
            }
        }
        return make_pair(rk, subject);
    }
};

void update1rank(vector<Student> &r, int idx)
{
    sort(r.begin(), r.end(), [idx] (Student &a, Student &b) {return a.grade[idx] > b.grade[idx];});
    for(int i=0; i<r.size(); ++i){
        if(i == 0)    r[0].rank[idx] = 1;
        else{
            if(r[i].grade[idx] == r[i-1].grade[idx])  r[i].rank[idx] = r[i-1].rank[idx];
            else    r[i].rank[idx] = i+1;
        }
    }
}

int main()
{
    //read 1-st line
    int N, M;
    cin >> N >> M;
    //read 2-nd part
    int stu_num, gC, gM, gE;
    vector<Student> record;
    for(int i=0; i<N; ++i){
        cin >> stu_num >> gC >> gM >> gE;
        record.push_back(Student(stu_num, gC, gM, gE));
    }
    /* ---- update rank ---- */
    // grade of C
    for(int i=0; i<4; i++)
        update1rank(record, i);
    // construct map
    map<int, Student> rcd_map;
    for(int i=0; i<record.size(); ++i)
        rcd_map[record[i].number] = record[i];

    //read the last part and search
    for(int i=0; i<M; ++i){
        cin >> stu_num;
        if(rcd_map.find(stu_num) == rcd_map.end())
            cout << "N/A" << endl;
        else{
            pair<int, char> rst = rcd_map[stu_num].best_rank();
            cout << rst.first << ' ' <<rst.second << endl;
        }
    }

    return 0;
}

注意:
1.平均成绩为四舍五入后的整数,给计算出的浮点数+0.5后再转为int即可。
2.成绩相同的人,名次并列。if(r[i].grade[idx] == r[i-1].grade[idx]) r[i].rank[idx] = r[i-1].rank[idx];

猜你喜欢

转载自blog.csdn.net/linlinlin96/article/details/79482794