PAT_甲级_1038

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/lzc842650834/article/details/87926656

1038 Recover the Smallest Number

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤104​​ ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

为了稳定性,之前做题一直用的char数组,然后想了半天没想起来怎么做orz,最后看的参考书。。

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string>
using namespace std;
const int maxn = 10010;
string str[maxn];
bool cmp(string a, string b)
{
    return a + b < b + a;
}
int main()
{
    int num;
    cin >> num;
    for (int i = 0; i < num; i++) {
        cin >> str[i];
    }
    sort(str, str + num, cmp);
    string result;
    for (int i = 0; i < num; i++) {
        result += str[i];
    }
    while (result.size() != 0 && result[0] == '0') {
        result.erase(result.begin());
    }
    if(result.size() == 0) {
        cout << '0' << endl;
    } else {
        cout << result << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lzc842650834/article/details/87926656