PAT甲级 1009 1012

1009 Product of Polynomials

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:
3 3 3.6 2 6.0 1 1.6

题目解析:
给出两个多项式A和B,让我们求A和B的乘积。输入的参数K为多项式的项数,Ni和aNi为每一项的次数和系数,计算A*B后按系数递减规则输出结果中非零项的项数以及每一项的次数和系数。代码中使用double类型的数组来存储多项式,数组的下标与多项式的次数对用,数组的值存储相应次数的系数。

#include <iostream>
using namespace std;
int main()
{
  int n, m, cishu, cnt = 0;
  // c用来存储相乘后的乘积,由于A和B的次数<=1000,所以最后相乘得到多项式次数最高会有2000
  double xishu, a[1001] = {0}, c[2001] = {0.0};
  cin >> n;
  for (int i = 0; i < n; i++)
  {
    cin >> cishu >> xishu;
    a[cishu] = xishu;
  }
  cin >> m;
  for (int i = 0; i < m; i++)
  {
    cin >> cishu >> xishu;
    for (int j = 0; j < 1001; j++)
      c[cishu + j] += xishu * a[j];
  }
  for (int i = 0; i < 2001; i++)
  {
    if (c[i] != 0)
      cnt++;
  }
  cout << cnt;
  for (int i = 2000; i >= 0; i--)
  {
    if (c[i] != 0)
      printf(" %d %.1f", i, c[i]);
  }
  return 0;
}

1012 The Best Rank

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101  98  85  88 90
310102  70  95  88 84
310103  82  87  94 88
310104  91  91  91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output N/A.

Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A

题目解析:
给出N个学生的ID以及每位学生C、M、E三门课的成绩,这样每位学生都有四个排名,分别的C课程的排名、M课程的排名、E课程的排名,以及平均分数的排名,之后给出M个学生的id,要求我们求出这M位学生四个排名中最好的那门课的排名,输出最好的排名位次以及对应课程的名称,如果存在相同好的排名,则按照 A > C > M > E 的规则输出;若输入的学生id未查找到,则输出N/A。
代码采用结构体的数据结构,每个node存储学生的id,四个成绩,四个排名,以及最好的排名对应的课程下标。

#include <iostream>
#include <algorithm>
using namespace std;

struct node
{
  int id, best;
  int score[4], rank[4];
} stu[2001];

int exist[1000000], flag = -1;

bool cmp1(node a, node b)
{
  return a.score[flag] > b.score[flag];
}

int main()
{
  int n, m, id;
  cin >> n >> m;
  for (int i = 0; i < n; i++)
  {
    cin >> stu[i].id >> stu[i].score[1] >> stu[i].score[2] >> stu[i].score[3];
    // +0.5用于四舍五入
    stu[i].score[0] = (stu[i].score[1] + stu[i].score[2] + stu[i].score[3]) / 3.0 + 0.5;
  }
  for (flag = 0; flag <= 3; flag++)
  {
    sort(stu, stu + n, cmp1);
    stu[0].rank[flag] = 1;
    for (int i = 1; i < n; i++)
    {
      stu[i].rank[flag] = i + 1;
      if (stu[i].score[flag] == stu[i - 1].score[flag])
        stu[i].rank[flag] = stu[i - 1].rank[flag];
    }
  }
  for (int i = 0; i < n; i++)
  {
    exist[stu[i].id] = i + 1;
    stu[i].best = 0;
    int min = stu[i].rank[0];
    for (int j = 1; j < 4; j++)
    {
      if (stu[i].rank[j] < min)
      {
        min = stu[i].rank[j];
        stu[i].best = j;
      }
    }
  }
  char c[5] = {'A', 'C', 'M', 'E'};
  for (int i = 0; i < m; i++)
  {
    cin >> id;
    int temp = exist[id];
    if (temp)
    {
      int best = stu[temp - 1].best;
      cout << stu[temp - 1].rank[best] << " " << c[best] << endl;
    }
    else
    {
      cout << "N/A" << endl;
    }
  }
  return 0;
}
    {
        min = stu[i].rank[j];
        stu[i].best = j;
      }
    }
  }
  char c[5] = {'A', 'C', 'M', 'E'};
  for (int i = 0; i < m; i++)
  {
    cin >> id;
    int temp = exist[id];
    if (temp)
    {
      int best = stu[temp - 1].best;
      cout << stu[temp - 1].rank[best] << " " << c[best] << endl;
    }
    else
    {
      cout << "N/A" << endl;
    }
  }
  return 0;
}

参考
https://github.com/liuchuo/PAT

猜你喜欢

转载自blog.csdn.net/m0_61974219/article/details/120831737