PAT_甲级_1024

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/lzc842650834/article/details/88124624

1024 Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​ ) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:
For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

更新的时候,注意先保存被改变并且还需用到的变量。

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string>
using namespace std;
string num;

int main()
{
    int n;
    cin >> num >> n;
    string temp = num;
    string a = "0";
    int flag = 0;
    int step = 0;
    while (step < n) {
        reverse(temp.begin(), temp.end());
        if (num == temp) {
            cout << temp << endl;
            cout << step << endl;
            flag = 1;
            break;
        } else {
            step++;
            int carry = 0;
            for (int i = int(num.size()) - 1; i >= 0; i--) {
                int temp_2 = num[i];   				//注意先设置临时变量保存num[i]
                num[i] = (num[i] - '0' + temp[i] - '0' + carry) % 10 + '0';
                carry = (temp_2 - '0' + temp[i] - '0' + carry) / 10;

            }

            if (carry != 0) {
                a[0] = carry + '0';
                num.insert(0, a);
            }

            temp = num;
        }
    }
    if (flag == 0) {
        cout << temp << endl;
        cout << step << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lzc842650834/article/details/88124624
今日推荐