PAT_甲级_1037

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/lzc842650834/article/details/87926279

1037 Magic Coupon

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​ , followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​ , followed by a line with N​P​​ product values. Here 1≤N​C​​ ,N​P​​ ≤105​​ , and it is guaranteed that all the numbers will not exceed 2
​30​​ .

Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

这题的错误都想打死自己。。。复制代码重用的时候,部分参数忘改。。。

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<vector>
using namespace std;
vector<int> a, b, c, d;
bool cmp_1(int a, int b)
{
    return a < b;
}
bool cmp_2(int a, int b)
{
    return a > b;
}
int main()
{
    int n, m;
    int temp;
    cin >> n;
    for (int i = 0; i < n; i++) {
        cin >> temp;
        if (temp > 0) {
            a.push_back(temp);
        } else if (temp < 0) {
            b.push_back(temp);
        }
    }
    cin >> m;
    for (int i = 0; i < m; i++) {
        cin >>temp;
        if (temp > 0) {
            c.push_back(temp);
        } else if (temp < 0) {
            d.push_back(temp);
        }
    }
    sort(a.begin(), a.end(), cmp_2);
    sort(b.begin(), b.end(), cmp_1);
    sort(c.begin(), c.end(), cmp_2);
    sort(d.begin(), d.end(), cmp_1);
    long long sum = 0;
    int len_1 = min(a.size(), c.size());

    for (int i = 0; i < len_1; i++) {
        sum += a[i] * c[i];
    }
    int len_2 = min(b.size(), d.size());
    cout << b.size()<< d.size();
    for (int i = 0; i < len_2; i++) {
        sum += b[i] * d[i];
    }
    cout << sum << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lzc842650834/article/details/87926279
今日推荐