PAT_甲级_1049

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/lzc842650834/article/details/88086786

1049 Counting Ones

The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

Input Specification:
Each input file contains one test case which gives the positive N (≤2​30​​ ).

Output Specification:
For each test case, print the number of 1’s in one line.

Sample Input:
12
Sample Output:
5

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string>
#include<string.h>
using namespace std;
int main()
{
    string num;
    int _count = 0;
    cin >> num;
    int len = num.size();
    for (int i = 0; i < len; i++) {
        string pre = num.substr(0, i);
        string post = num.substr(i + 1, len - i + 1);
        int temp = 1;
        for (int j = 0; j < post.size(); j++) {
            temp *= 10;
        }
        if (num[i] == '0') {
            _count += (atoi(pre.c_str())) * temp;
        } else if (num[i] == '1') {
            _count += ((atoi(pre.c_str())) * temp + atoi(post.c_str()) + 1);
        } else {
            _count += (atoi(pre.c_str()) + 1) * temp;
        }
    }

    cout << _count;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lzc842650834/article/details/88086786